PowerWeb 虛擬主機
客服中心 首頁 > 常見問題資料庫 > Linux 虛擬主機設定問題

常見問題類別     
 
   虛擬主機租用、繳費問題
   虛擬主機使用管理問題
   虛擬主機使用規定及違規處理方式
   虛擬主機郵件信箱設定及使用方式
   虛擬主機MySQL資料庫設定上傳方式
   網域名稱申請/使用問題
   Windows 虛擬主機設定問題
   Linux 虛擬主機設定問題
 
 

 

使用 .htaccess 變更 PHP 版本 (PHP5.4、PHP5.5、PHP5.6、PHP7.0、PHP7.1)

如虛擬主機 PHP 運行於 CGI/FastCGI 模式下,可提供虛擬主機用戶利用 .htaccess 檔案自行變更/選擇 PHP 運行版本。

例如在 .htaccess 添加下列設定:
 

PHP 5.6 

Options +ExecCGI
<FilesMatch \.php$>
SetHandler fcgid-script
</FilesMatch>
FCGIWrapper /usr/bin/php56m-cgi .php

 

PHP 7.1

Options +ExecCGI
<FilesMatch \.php$>
SetHandler fcgid-script
</FilesMatch>
FCGIWrapper /usr/bin/php71m-cgi .php

 

其中 「FCGIWrapper /usr/bin/phpXXm-cgi .php」為指定欲使用的 PHP 版本代號,目前支援「PHP5.4」、「PHP5.5」、「PHP5.6」、「PHP7.0」、「PHP7.1」。

例如:php54m-cgi、php55m-cgi、php56m-cgi、php70m-cgi、php71m-cgi。

 

需注意,.htaccess 檔案可放置於根目錄或其它子目錄中,使同一網站內各子目錄運行不同的 PHP 版本(Multiple Versions of PHP on One Server)。如欲設定 PHP 參數時需改用 .user.ini (勿於 .htaccess 檔案內使用 php_flag 等標籤),詳細內容請參閱「使用 PHP .user.ini 自訂參數值設定檔」 。

 

 

   回上一頁   
 
PowerWeb 虛擬主機 / 網域名稱服務中心
 





POWERWEB 虛擬主機網頁空間 © 2004~2017 KangYu Inc. All Rights Reserved. 諮詢專線 0809-058-688 服務時間 週一~週五 09:00 ~ 18:00‧ 傳真電話 (02) 3322-9019
線上信用卡授權